Network

Running NX-OSv 9000 on eve (UNL)

Refer to how to add NX-OXv 9000 to GNS3

  1. Download necessary components
    • The NX-OSv9k image file from Cisco (nxosv-final.7.0.3.I5.1.qcow2). Please note that you must have a service contract with Cisco in order to download it. No, I can’t provide the image for you.
  2. Copy image to eve
    • change file name to ‘hda.qcow2’
    • copy source file to ‘/opt/unetlab/addons/qemu/nxosv9k-7.0.3.I5.1’
    • run ‘/opt/unetlab/wrappers/unl_wrapper -a fixpermissions’
  3. Add a New node of Cisco NX-OSv 9k
    • Console : ‘telnet’
  4. Start the node
    • This step needs your patient because the terminal will be shown as a blank screen for a while (about 15 – 20 seconds). The boot process takes about minutes.
    • It prompts you: Abort Auto Provisioning and continue with normal setup ?(yes/no)[n]: y
  5. Done
    • nx9kboot

The advantage of eve is it already improved Qemu with UEFI for Cisco Nexus9Kv.

More info:

Advertisements

35 thoughts on “Running NX-OSv 9000 on eve (UNL)

  1. Thank your for the article.
    At first my NXOS node did not start. I had a standard EVE-NG specs, 4 CPU and 4G RAM. After I increased the EVE-NG specs to 8G RAM the NXOS now runs..

    Like

  2. i am trying to run nx-osv ( nxosv9k-7.0.3.15.1 ) on EVE-NG, but it do not work, please mentioned the remedy way forward, as when i try to run the nx-osv it starts ( become blue ) for a moment for soon after it become gray again, running on laptop with 16 Gb memory

    Like

  3. Hi Kevin,

    I am getting below screen and it is not moving forward further. Please help What caused the issue.

    My Eve-ng version is |/ Name Version Architecture Description
    +++-===========================================-==========================-==========================-===========================================================================================
    ii eve-ng 2.0.3-60 amd64 A new generation software for networking labs.
    root@eve-ng:~#

    Boot Failed. EFI Floppy
    Boot Failed. EFI Floppy 1
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(0,0,0)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(0,0,0)/HD(1,800,8000,c48fa7a2-22f0-4149-d4bc-1993e4cf76c1)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(0,0,0)/HD(2,8800,a3332,e717d076-a237-41f2-8081-f2c4fe637289)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(0,0,0)/HD(3,ac000,146666,79914cb2-73d2-4fb9-1999-b15f771375a6)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(0,0,0)/HD(4,1f2800,6b199c,5330e85f-6426-43dd-e986-056152ac5679)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(0,0,0)/HD(5,8a4800,146666,aa000172-ffda-4794-9d8e-444ba967be56)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(0,0,0)/HD(6,9eb000,146666,6fb3e8b7-501e-4b25-f791-787af6874f46)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(0,0,0)/HD(7,b31800,4c8000,a9c6e5c0-20cd-4bb0-5895-154fa6daee2d)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(1,0,0)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(1,0,0)/HD(1,800,8000,c48fa7a2-22f0-4149-d4bc-1993e4cf76c1)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(1,0,0)/HD(2,8800,a3332,e717d076-a237-41f2-8081-f2c4fe637289)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(1,0,0)/HD(3,ac000,146666,79914cb2-73d2-4fb9-1999-b15f771375a6)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(1,0,0)/HD(4,1f2800,6b199c,5330e85f-6426-43dd-e986-056152ac5679)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(1,0,0)/HD(5,8a4800,146666,aa000172-ffda-4794-9d8e-444ba967be56)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(1,0,0)/HD(6,9eb000,146666,6fb3e8b7-501e-4b25-f791-787af6874f46)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(1,0,0)/HD(7,b31800,4c8000,a9c6e5c0-20cd-4bb0-5895-154fa6daee2d)/EndEntire
    /ACPI(a0341d0,0)/PCI(0,1)/ACPI(60441d0,0)/EndEntire
    /ACPI(a0341d0,0)/PCI(0,1)/ACPI(60441d0,1)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(0,0,0)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(0,0,0)/HD(1,800,8000,c48fa7a2-22f0-4149-d4bc-1993e4cf76c1)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(0,0,0)/HD(2,8800,a3332,e717d076-a237-41f2-8081-f2c4fe637289)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(0,0,0)/HD(3,ac000,146666,79914cb2-73d2-4fb9-1999-b15f771375a6)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(0,0,0)/HD(4,1f2800,6b199c,5330e85f-6426-43dd-e986-056152ac5679)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(0,0,0)/HD(5,8a4800,146666,aa000172-ffda-4794-9d8e-444ba967be56)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(0,0,0)/HD(6,9eb000,146666,6fb3e8b7-501e-4b25-f791-787af6874f46)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(0,0,0)/HD(7,b31800,4c8000,a9c6e5c0-20cd-4bb0-5895-154fa6daee2d)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(1,0,0)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(1,0,0)/HD(1,800,8000,c48fa7a2-22f0-4149-d4bc-1993e4cf76c1)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(1,0,0)/HD(2,8800,a3332,e717d076-a237-41f2-8081-f2c4fe637289)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(1,0,0)/HD(3,ac000,146666,79914cb2-73d2-4fb9-1999-b15f771375a6)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(1,0,0)/HD(4,1f2800,6b199c,5330e85f-6426-43dd-e986-056152ac5679)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(1,0,0)/HD(5,8a4800,146666,aa000172-ffda-4794-9d8e-444ba967be56)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(1,0,0)/HD(6,9eb000,146666,6fb3e8b7-501e-4b25-f791-787af6874f46)/EndEntire
    /ACPI(a0341d0,0)/PCI(1,1)/ATAPI(1,0,0)/HD(7,b31800,4c8000,a9c6e5c0-20cd-4bb0-5895-154fa6daee2d)/EndEntire
    /ACPI(a0341d0,0)/PCI(0,1)/ACPI(60441d0,0)/EndEntire
    /ACPI(a0341d0,0)/PCI(0,1)/ACPI(60441d0,1)/EndEntire
    Total memory is 0xa0000
    Total memory is 0xbee3c000
    Sysconf checksum failed. Using default values
    WARNING: No BIOS Info found
    Sysconf checksum failed. Using default values
    serial –speed=115200 –word=8 –stop=1 –parity=no

    success
    Sysconf checksum failed. Using default values
    Strlen bootflash: is 10
    Device bootflash: is Drive 0x80 Partition 3
    Strlen bootflash: is 10
    Device bootflash: is Drive 0x81 Partition 3
    ATE0Q1&D2&C1S0=1
    Trying to read config file /boot/grub/menu.lst.local from (hd0,4)
    Filesystem type is ext2fs, partition type 0x83
    Number of devices detected by BIOS is 2
    Failed. Trying to read config file from (hd0,5)
    Filesystem type is ext2fs, partition type 0x83
    Number of devices detected by BIOS is 2

    Like

  4. Thanks for the Guide!
    I have no success with booting the n9k, it turns blue for a short amount of time and then becomes grey again…
    Was not able to find the correct logs, can you help me here?

    Like

  5. the node only work on the first startup. When I reboot it, it will boot fail and go to “loader” prompt. Anyone have this issue?

    Like

      1. It’s known issue: http://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus9000/sw/7-x/nx-osv/configuration/guide/b_NX-OSv_9000/b_NX-OSv_9000_chapter_010.html

        ….
        How to prevent VM from dropping into “loader >” prompt
        As soon as you set up your NX-OSv 9000 (following set up of POAP interface), you need to configure the boot image in your system to avoid dropping to the “loader >” prompt after reload/shut down.

        Example:
        config t
        boot nxos n9000-dk9.7.0.3.I2.0.454.bin
        copy running starting

        Liked by 1 person

  6. Hi,
    I’m always getting the following error:

    Total memory is 0xa0000
    Total memory is 0xbee3c000
    Sysconf checksum failed. Using default values
    WARNING: No BIOS Info found
    Sysconf checksum failed. Using default values
    serial –speed=115200 –word=8 –stop=1 –parity=no

    success
    Sysconf checksum failed. Using default values
    Strlen bootflash: is 10
    Device bootflash: is Drive 0x80 Partition 3
    Strlen bootflash: is 10
    Device bootflash: is Drive 0x81 Partition 3
    ATE0Q1&D2&C1S0=1
    Trying to read config file /boot/grub/menu.lst.local from (hd0,4)
    Filesystem type is ext2fs, partition type 0x83
    Number of devices detected by BIOS is 2
    Failed. Trying to read config file from (hd0,5)
    Filesystem type is ext2fs, partition type 0x83
    Number of devices detected by BIOS is 2

    I tried to add 16G RAM and 4 CPU and still the same. I reinstalled EVE from scratch without joy.

    Any suggestion?
    Thanks.

    Like

      1. Hello,
        Just updated to latest 2.0.3.60 and I’m getting the same issue. I downloaded different version of NXOSv and different BIOS but still crashes at the same point. I believe this will be some sort of hardware issue on my server. Will try on a different server.

        Like

    1. Do you resolve this issue? I have the same… I have reboot at loading stage like this:
      Loading [640M/717M]
      *** reboot***

      or after it:
      Populating conf files for hybrid sysmgr …
      Starting hybrid sysmgr …
      All gzip files are: /var/sysmgr/core_restore/0x101_event_manager_core.25629.gz
      Unzipping /var/sysmgr/core_restore/0x101_event_manager_core.25629.gz
      Moving /var/sysmgr/core_restore/0x101_event_manager_core.25629 to /var/sysmgr/tmp_logs
      Moving /var/sysmgr/core_restore/0x101_event_manager_log.25629 to /var/sysmgr/tmp_logs
      inserting /isan/lib/modules/klm_cisco_nb.o … done
      Apr 11 08:24:45 %SYSMGR-2-LAST_CORE_BASIC_TRACE : PID 23874 with message sharedmemmgr(non-sysmgr) crashed, core will be saved .

      Apr 11 08:24:57 %SYSMGR-3-CORE_OP_FAILED Core operation failed: send_msg_to_ccdmon: Could not send to CORE_DMON return -1 errno 32
      Apr 11 08:25:14 %SYSMGR-2-HAP_FAILURE_SUP_RESET Service “policyelem” in vdc 1 has had a hap failure
      [ 141.987502] [1491899121] Restarting system.
      *** reboot ***

      And I don’t know how to make it works

      Like

      1. I have 6×4 CPU and 16 GB RAM. Don’t think that problem is in allocated resources to my VM (ESXi)… But i will try to raise it some more

        Like

    2. I am facing with the same issue and totally have no idea even if I import OVA in vmware workstation. I guess it seems to be some hardware support issue, will try in server soon.

      Like

  7. Hello Kevin,

    I have been doing some testing and I can say that this image supports VPC! This is pretty cool and so exciting as I can have a working lab about it and move on to DC track.

    This is what a done in this lab:

    1) Enable the feature VPC, LACP and interface vlan on both 9K nodes: (I got no error so this is a good sign)

    feature interface-vlan
    feature lacp
    feature vpc

    2) Set up STP features and a VDC domain

    spanning-tree loopguard default
    spanning-tree vlan 1-100 priority 4096
    vrf context management
    vpc domain 1
    peer-switch
    role priority 1
    peer-keepalive destination 192.168.1.2 source 192.168.1.1 #(on the other 9K the IP is the opposite)
    delay restore 150
    auto-recovery

    3) Create a PO interface for vpc peer-link

    interface port-channel1
    switchport mode trunk
    spanning-tree port type network
    vpc peer-link

    4) Bind the created PO int to the ethernet interfaces (They are connected between the 9Ks)

    interface Ethernet1/1
    switchport mode trunk
    channel-group 1

    interface Ethernet1/2
    switchport mode trunk
    channel-group 1

    5) The interface mgmt 0 I used for the peer keep-alive

    interface mgmt0
    speed 100
    duplex full
    vrf member management
    ip address 192.168.1.1/30

    6) Let’s check the VPC peer status (Great we have connectivity and the peer is up)

    NXOS-1# sh vpc
    Legend:
    (*) – local vPC is down, forwarding via vPC peer-link

    vPC domain id : 1
    Peer status : peer adjacency formed ok
    vPC keep-alive status : peer is alive
    Configuration consistency status : success
    Per-vlan consistency status : success
    Type-2 consistency status : success
    vPC role : primary
    Number of vPCs configured : 1

    7) Setting up the PO interface to the access switch (on both 9K)

    interface port-channel10
    description to ASW1
    switchport mode trunk
    vpc 10

    interface Ethernet1/3
    description to ASW1
    switchport mode trunk
    channel-group 10

    8) Setup the PO Interface on ASW1

    interface port-channel1
    switchport mode trunk

    interface Ethernet0/0
    description to NXOS-1
    switchport mode trunk
    channel-group 1 mode on

    interface Ethernet0/1
    description to NXOS-2
    switchport mode trunk
    channel-group 1 mode on

    9) Checking the PO interface on ASW1

    ASW1#sh etherchannel summary
    Flags: D – down P – bundled in port-channel
    I – stand-alone s – suspended
    H – Hot-standby (LACP only)
    R – Layer3 S – Layer2
    U – in use f – failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port
    

    Number of channel-groups in use: 1
    Number of aggregators: 1

    Group Port-channel Protocol Ports
    ——+————-+———–+———————————————–
    1 Po1(SU) – Et0/0(P) Et0/1(P)

    This was pretty cool! Thanks for your posts…

    Like

  8. when I try to run two Nexus 9K on EVE one works fine but the other keeps crashing and restarting…Do you know what may be causing this?

    Here are some logs:

    …..

    Populating conf files for hybrid sysmgr …
    Starting hybrid sysmgr …
    All gzip files are: /var/sysmgr/core_restore/0x101_event_manager_core.25005.gz
    Unzipping /var/sysmgr/core_restore/0x101_event_manager_core.25005.gz
    Moving /var/sysmgr/core_restore/0x101_event_manager_core.25005 to /var/sysmgr/tp_logs
    Moving /var/sysmgr/core_restore/0x101_event_manager_log.25005 to /var/sysmgr/tm_logs
    inserting /isan/lib/modules/klm_cisco_nb.o … done
    Mar 31 15:21:56 %SYSMGR-2-LAST_CORE_BASIC_TRACE : PID 23707 with message sharedemmgr(non-sysmgr) crashed, core will be saved .

    Mar 31 15:22:08 %SYSMGR-3-CORE_OP_FAILED Core operation failed: send_msg_to_ccdon: Could not send to CORE_DMON return -1 errno 32
    Mar 31 15:22:23 %SYSMGR-2-HAP_FAILURE_SUP_RESET Service “policyelem” in vdc 1 hs had a hap failure
    [ 237.938707] [1490973748] Restarting system.

    thks

    Like

      1. Hello Kevin,

        Thank for the reply. Yes, you were right, not enough RAM was causing the reboot. It appears each 9K needs 8GB of RAM to run. So I changed to 16GB of reserved memory and it did run. I only have 8GB om my laptop but it worked even swap memory.

        Thanks, man!

        Liked by 1 person

  9. hello there,

    Does it support VPC, VDC?

    Is it just the limited version with a few features and no data plane?

    I ran 7K titanium on eve and im a bit disappointed…no working data plane, no lacp means no vpc and so on…

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s